Работа с файлами XML

Формат файлов который занимает лидирующее положение в мире при обмене данными.

Делаем эксперимент для изучения этого формата:

 

ЗАПИСЬ В ФАЙЛ XML

Создаем чистую конфигурацию и добавляем справочник Организации

Выгружаем справочник в XML:

&НаСервере
Процедура _ЗаписатьXMLНаСервере()

ЗаписьXML = Новый ЗаписьXML;
ЗаписьXML.ОткрытьФайл(«d:\Temp\Test.XML», «UTF-8»); //Открываем файл для записи, указываем кодировку
ЗаписьXML.ЗаписатьОбъявлениеXML(); // Записываем объявление XML

ЗаписьXML.ЗаписатьНачалоЭлемента(«Организации»); // Начало элемента Организации
ЗаписьXML.ЗаписатьНачалоЭлемента(«НашиОрганизации»); // Начало элемента Организации
Выборка = Справочники.Организации.Выбрать();
Пока Выборка.Следующий() Цикл // Начинаем выгружать организации
ЗаписьXML.ЗаписатьНачалоЭлемента(«Организация»); // Начало элемента Организация
ЗаписьXML.ЗаписатьАтрибут(«Код»,Строка(Выборка.Код));
ЗаписьXML.ЗаписатьАтрибут(«Наименование»,Строка(Выборка.Наименование));
ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента Организация
КонецЦикла;
ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента Организация

ЗаписьXML.ЗаписатьНачалоЭлемента(«ЧужиеОрганизации»); // Начало элемента Организации
Выборка = Справочники.Организации.Выбрать();
Пока Выборка.Следующий() Цикл // Начинаем выгружать организации
ЗаписьXML.ЗаписатьНачалоЭлемента(«Организация»); // Начало элемента Организация
ЗаписьXML.ЗаписатьАтрибут(«Код»,Строка(Выборка.Код));
ЗаписьXML.ЗаписатьАтрибут(«Наименование»,Строка(Выборка.Наименование));
ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента Организация
КонецЦикла;
ЗаписьXML.ЗаписатьКонецЭлемента();
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.Закрыть();
КонецПроцедуры

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • Twitter
  • RSS

Merkatura — Простейшая настройка 1С по управлению складом

Настройка разработано мною.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • Twitter
  • RSS

Здесь будет собрана информация о web-сервисах

Здесь будет собрана информация о web-сервисах

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • Twitter
  • RSS

Привет, всем!

Добро пожаловать на блог программиста 1С. Здесь будет собираться информация о работе программы 1С!

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • Twitter
  • RSS